1 Отредактировано Andrei_Ts (13-01-2017 18:28:24)

Тема: [Решено] страницам в категории не присваиваются урлы

Страницам в категории не присваиваются урлы

Версия движка: 4.12 Corporate
Версия ОС: Windows 7
Версия браузера: 55.0.2883.87 m (64-bit)
Окружение: Linux myweb09.bn.by 3.2.0-4-amd64 #1 SMP Debian 3.2.82-1 x86_64  HTTP: Apache/2.2.22 (Debian) DAV/2 mod_fcgid  PHP: PHP-5.5.38  СУБД: MySQL-5.1.67

Путь к ошибке:
1.    Создаете новую страницу в любом разделе
2.    Заполняете контент
3.    Сохраняете
4.    Переходите в браузере в раздел в котором создана страница
5.    Сам заголовок страницы с описанием есть в разделе - но без урла на саму страницу
6.    В самой админке в кнопке "показать на сайте" урл на страницу есть

Система практически без самопальных или других аддонов. В 4.11 все было нормально. Обновление до 4.12 делалось накаткой файлов из пакета обновления и обновлением БД - все прошло без ошибок и с первого раза. Очистка кэша системы не помогает.

Thumbs up Thumbs down

2 Отредактировано Andrei_Ts (02-01-2017 20:46:40)

Re: [Решено] страницам в категории не присваиваются урлы

UP темы, дабы не ускакала в недра форума. И господа разрабы... решите проблему оперативно, потому что менеджеры пишут периодически статейки в разные разделы магазина, а линки не появляются и вся идет наперекосяк.

Thumbs up Thumbs down

3

Re: [Решено] страницам в категории не присваиваются урлы

Блин, господа разработчики, предложите хотя бы какой-то временный фикс - я понимаю что Вам удобнее в следующую версию системы запихнуть исправление - но юзеры-то не хотят ждать пока Вы разродитесь новой версией и апдейтом для текущей.

Thumbs up Thumbs down

4 Отредактировано Andrei_Ts (13-01-2017 18:29:15)

Re: [Решено] страницам в категории не присваиваются урлы

Так... проблему решил сам. Оказалось, был косяк в шаблоне: в месте вывода ссылки нужно было выводить УРЛ таким образом - {site_url($p.full_url)}

Но хочется кинуть, так сказать, "камень" в "огород" разработчиков. За все это время НИ ОДИН человек из суппорта или программеров (уж не знаю кто там занимается баг-трекингом) даже не спросил деталей ошибки, не попросил выложить хотя бы исходники тпл-ки - только втирали что мол проблема известная и мы работаем над её решением. А бага-то собственно никакого и нет, а разрабы продолжают "решать баг"... Вот так... ))))))))

Печально, что на проблемы легальных кастомеров контора тупо забивает...

Thumbs up Thumbs down